Show / Hide Table of Contents

Class AliasNetworkEndpoint

Represents an Alias Network Endpoint resource. To be used for GKE pod-native endpoints in Andromeda.

Inheritance
object
AliasNetworkEndpoint
Implements
IDirectResponseSchema
Inherited Members
object.Equals(object)
object.Equals(object, object)
object.GetHashCode()
object.GetType()
object.MemberwiseClone()
object.ReferenceEquals(object, object)
object.ToString()
Namespace: Google.Apis.Compute.preview.Data
Assembly: Google.Apis.Compute.preview.dll
Syntax
public class AliasNetworkEndpoint : IDirectResponseSchema

Properties

Aliases

Required. The map of network aliases allocated for the AliasNetworkEndpoint. This map is keyed with user-provided alias names.

Declaration
[JsonProperty("aliases")]
public virtual IDictionary<string, AliasNetworkEndpointAlias> Aliases { get; set; }
Property Value
Type Description
IDictionary<string, AliasNetworkEndpointAlias>

Annotations

Optional. The annotations map for the AliasNetworkEndpoint. Keys and values must follow Kubernetes limits. Keys must be a maximum of 253 characters. Keys should be dot-namespaced, following the Kubernetes annotation key format: ([DNS subdomain]/)?[RFC 1123 name]. Values must be a maximum of 256 characters.

Declaration
[JsonProperty("annotations")]
public virtual IDictionary<string, string> Annotations { get; set; }
Property Value
Type Description
IDictionary<string, string>

CreationTimestamp

Output only. [Output Only] Creation timestamp in RFC3339 text format.

Declaration
[JsonProperty("creationTimestamp")]
public virtual string CreationTimestamp { get; set; }
Property Value
Type Description
string

Description

Optional. An optional description of this resource. Provide this field when you create the resource.

Declaration
[JsonProperty("description")]
public virtual string Description { get; set; }
Property Value
Type Description
string

ETag

The ETag of the item.

Declaration
public virtual string ETag { get; set; }
Property Value
Type Description
string

Host

Required. The host that the alias network endpoint is bound to.

Declaration
[JsonProperty("host")]
public virtual AliasNetworkEndpointHost Host { get; set; }
Property Value
Type Description
AliasNetworkEndpointHost

Id

Output only. [Output Only] The unique identifier for the resource. This identifier is defined by the server.

Declaration
[JsonProperty("id")]
public virtual ulong? Id { get; set; }
Property Value
Type Description
ulong?

Labels

Optional. The labels map for the AliasNetworkEndpoint.

Declaration
[JsonProperty("labels")]
public virtual IDictionary<string, string> Labels { get; set; }
Property Value
Type Description
IDictionary<string, string>

Name

Identifier. Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply with RFC1035.

Declaration
[JsonProperty("name")]
public virtual string Name { get; set; }
Property Value
Type Description
string

SecurityTagInheritance

Optional. The security tag inheritance setting for the AliasNetworkEndpoint.

Declaration
[JsonProperty("securityTagInheritance")]
public virtual string SecurityTagInheritance { get; set; }
Property Value
Type Description
string

SelfLink

Output only. [Output Only] Server-defined URL for the resource.

Declaration
[JsonProperty("selfLink")]
public virtual string SelfLink { get; set; }
Property Value
Type Description
string

Status

Output only. [Output Only] Current status of the alias network endpoint.

Declaration
[JsonProperty("status")]
public virtual AliasNetworkEndpointStatus Status { get; set; }
Property Value
Type Description
AliasNetworkEndpointStatus

Subnetwork

Required. The URL of the subnetwork that this alias network endpoint belongs to.

Declaration
[JsonProperty("subnetwork")]
public virtual string Subnetwork { get; set; }
Property Value
Type Description
string

UpdateTime

Output only. [Output Only] Update timestamp in RFC3339 text format.

Declaration
[JsonProperty("updateTime")]
public virtual string UpdateTime { get; set; }
Property Value
Type Description
string

Implements

IDirectResponseSchema
In this article
Back to top Generated by DocFX