As of January 1, 2020 this library no longer supports Python 2 on the latest released version. Library versions released prior to that date will continue to be available. For more information please visit Python 2 support on Google Cloud.

Language Client API Reference

This package includes clients for multiple versions of the Natural Language API. By default, you will get v1, the latest GA version.

If you are interested in beta features ahead of the latest GA, you may opt-in to the v1.1 beta, which is spelled v1beta2. In order to do this, you will want to import from google.cloud.language_v1beta2 in lieu of google.cloud.language.

An API and type reference is provided for the v1.1 beta also:

Migration Guide

See the guide below for instructions on migrating to the 2.x release of this library.

Note

The client for the beta API is provided on a provisional basis. The API surface is subject to change, and it is possible that this client will be deprecated or removed after its features become GA.