Class: Google::Apis::CloudresourcemanagerV2beta1::GetPolicyOptions

Inherits:
Object
  • Object
show all
Includes:
Google::Apis::Core::Hashable, Google::Apis::Core::JsonObjectSupport
Defined in:
generated/google/apis/cloudresourcemanager_v2beta1/classes.rb,
generated/google/apis/cloudresourcemanager_v2beta1/representations.rb,
generated/google/apis/cloudresourcemanager_v2beta1/representations.rb

Overview

Encapsulates settings provided to GetIamPolicy.

Instance Attribute Summary collapse

Instance Method Summary collapse

Methods included from Google::Apis::Core::JsonObjectSupport

#to_json

Methods included from Google::Apis::Core::Hashable

process_value, #to_h

Constructor Details

#initialize(**args) ⇒ GetPolicyOptions

Returns a new instance of GetPolicyOptions.



437
438
439
# File 'generated/google/apis/cloudresourcemanager_v2beta1/classes.rb', line 437

def initialize(**args)
   update!(**args)
end

Instance Attribute Details

#requested_policy_versionFixnum

Optional. The policy format version to be returned. Valid values are 0, 1, and 3. Requests specifying an invalid value will be rejected. Requests for policies with any conditional bindings must specify version 3. Policies without any conditional bindings may specify any valid value or leave the field unset. To learn which resources support conditions in their IAM policies, see the IAM documentation. Corresponds to the JSON property requestedPolicyVersion

Returns:

  • (Fixnum)


435
436
437
# File 'generated/google/apis/cloudresourcemanager_v2beta1/classes.rb', line 435

def requested_policy_version
  @requested_policy_version
end

Instance Method Details

#update!(**args) ⇒ Object

Update properties of this object



442
443
444
# File 'generated/google/apis/cloudresourcemanager_v2beta1/classes.rb', line 442

def update!(**args)
  @requested_policy_version = args[:requested_policy_version] if args.key?(:requested_policy_version)
end