Class: Google::Apis::ComposerV1beta1::SoftwareConfig

Inherits:
Object
  • Object
show all
Includes:
Google::Apis::Core::Hashable, Google::Apis::Core::JsonObjectSupport
Defined in:
generated/google/apis/composer_v1beta1/classes.rb,
generated/google/apis/composer_v1beta1/representations.rb,
generated/google/apis/composer_v1beta1/representations.rb

Overview

Specifies the selection and configuration of software inside the environment.

Instance Attribute Summary collapse

Instance Method Summary collapse

Methods included from Google::Apis::Core::JsonObjectSupport

#to_json

Methods included from Google::Apis::Core::Hashable

process_value, #to_h

Constructor Details

#initialize(**args) ⇒ SoftwareConfig

Returns a new instance of SoftwareConfig.



847
848
849
# File 'generated/google/apis/composer_v1beta1/classes.rb', line 847

def initialize(**args)
   update!(**args)
end

Instance Attribute Details

#airflow_config_overridesHash<String,String>

Optional. Apache Airflow configuration properties to override. Property keys contain the section and property names, separated by a hyphen, for example "core-dags_are_paused_at_creation". Section names must not contain hyphens ("-"), opening square brackets ("["), or closing square brackets ("]"). The property name must not be empty and must not contain an equals sign ("=") or semicolon (";"). Section and property names must not contain a period ("."). Apache Airflow configuration property names must be written in snake_case. Property values can contain any character, and can be written in any lower/upper case format. Certain Apache Airflow configuration property values are blacklisted, and cannot be overridden. Corresponds to the JSON property airflowConfigOverrides

Returns:

  • (Hash<String,String>)


781
782
783
# File 'generated/google/apis/composer_v1beta1/classes.rb', line 781

def airflow_config_overrides
  @airflow_config_overrides
end

#env_variablesHash<String,String>

Optional. Additional environment variables to provide to the Apache Airflow scheduler, worker, and webserver processes. Environment variable names must match the regular expression a-zA-Z_*. They cannot specify Apache Airflow software configuration overrides (they cannot match the regular expression AIRFLOW__[A-Z0-9_]+__[A-Z0-9_]+), and they cannot match any of the following reserved names:

  • AIRFLOW_HOME
  • C_FORCE_ROOT
  • CONTAINER_NAME
  • DAGS_FOLDER
  • GCP_PROJECT
  • GCS_BUCKET
  • GKE_CLUSTER_NAME
  • SQL_DATABASE
  • SQL_INSTANCE
  • SQL_PASSWORD
  • SQL_PROJECT
  • SQL_REGION
  • SQL_USER Corresponds to the JSON property envVariables

Returns:

  • (Hash<String,String>)


805
806
807
# File 'generated/google/apis/composer_v1beta1/classes.rb', line 805

def env_variables
  @env_variables
end

#image_versionString

The version of the software running in the environment. This encapsulates both the version of Cloud Composer functionality and the version of Apache Airflow. It must match the regular expression composer-([0-9]+\.[0-9]+\.[0-9]+|latest)-airflow-[0-9]+\.[0-9]+(\.[0-9]+.*)?. When used as input, the server also checks if the provided version is supported and denies the request for an unsupported version. The Cloud Composer portion of the version is a semantic version or latest. When the patch version is omitted, the current Cloud Composer patch version is selected. When latest is provided instead of an explicit version number, the server replaces latest with the current Cloud Composer version and stores that version number in the same field. The portion of the image version that follows airflow- is an official Apache Airflow repository release name. See also Version List. Corresponds to the JSON property imageVersion

Returns:

  • (String)


826
827
828
# File 'generated/google/apis/composer_v1beta1/classes.rb', line 826

def image_version
  @image_version
end

#pypi_packagesHash<String,String>

Optional. Custom Python Package Index (PyPI) packages to be installed in the environment. Keys refer to the lowercase package name such as "numpy" and values are the lowercase extras and version specifier such as "==1.12.0", "[devel,gcp_api]", or "[devel]>=1.8.2, <1.9.2". To specify a package without pinning it to a version specifier, use the empty string as the value. Corresponds to the JSON property pypiPackages

Returns:

  • (Hash<String,String>)


837
838
839
# File 'generated/google/apis/composer_v1beta1/classes.rb', line 837

def pypi_packages
  @pypi_packages
end

#python_versionString

Optional. The major version of Python used to run the Apache Airflow scheduler, worker, and webserver processes. Can be set to '2' or '3'. If not specified, the default is '2'. Cannot be updated. Corresponds to the JSON property pythonVersion

Returns:

  • (String)


845
846
847
# File 'generated/google/apis/composer_v1beta1/classes.rb', line 845

def python_version
  @python_version
end

Instance Method Details

#update!(**args) ⇒ Object

Update properties of this object



852
853
854
855
856
857
858
# File 'generated/google/apis/composer_v1beta1/classes.rb', line 852

def update!(**args)
  @airflow_config_overrides = args[:airflow_config_overrides] if args.key?(:airflow_config_overrides)
  @env_variables = args[:env_variables] if args.key?(:env_variables)
  @image_version = args[:image_version] if args.key?(:image_version)
  @pypi_packages = args[:pypi_packages] if args.key?(:pypi_packages)
  @python_version = args[:python_version] if args.key?(:python_version)
end