Class: Google::Apis::ContaineranalysisV1beta1::VulnerabilityLocation

Inherits:
Object
  • Object
show all
Includes:
Google::Apis::Core::Hashable, Google::Apis::Core::JsonObjectSupport
Defined in:
generated/google/apis/containeranalysis_v1beta1/classes.rb,
generated/google/apis/containeranalysis_v1beta1/representations.rb,
generated/google/apis/containeranalysis_v1beta1/representations.rb

Overview

The location of the vulnerability.

Instance Attribute Summary collapse

Instance Method Summary collapse

Methods included from Google::Apis::Core::JsonObjectSupport

#to_json

Methods included from Google::Apis::Core::Hashable

process_value, #to_h

Constructor Details

#initialize(**args) ⇒ VulnerabilityLocation

Returns a new instance of VulnerabilityLocation.



3224
3225
3226
# File 'generated/google/apis/containeranalysis_v1beta1/classes.rb', line 3224

def initialize(**args)
   update!(**args)
end

Instance Attribute Details

#cpe_uriString

Required. The CPE URI in cpe format format. Examples include distro or storage location for vulnerable jar. Corresponds to the JSON property cpeUri

Returns:

  • (String)


3212
3213
3214
# File 'generated/google/apis/containeranalysis_v1beta1/classes.rb', line 3212

def cpe_uri
  @cpe_uri
end

#packageString

Required. The package being described. Corresponds to the JSON property package

Returns:

  • (String)


3217
3218
3219
# File 'generated/google/apis/containeranalysis_v1beta1/classes.rb', line 3217

def package
  @package
end

#versionGoogle::Apis::ContaineranalysisV1beta1::Version

Version contains structured information about the version of a package. Corresponds to the JSON property version



3222
3223
3224
# File 'generated/google/apis/containeranalysis_v1beta1/classes.rb', line 3222

def version
  @version
end

Instance Method Details

#update!(**args) ⇒ Object

Update properties of this object



3229
3230
3231
3232
3233
# File 'generated/google/apis/containeranalysis_v1beta1/classes.rb', line 3229

def update!(**args)
  @cpe_uri = args[:cpe_uri] if args.key?(:cpe_uri)
  @package = args[:package] if args.key?(:package)
  @version = args[:version] if args.key?(:version)
end