Module: Google::Cloud::PolicyTroubleshooter::V1

Defined in:
lib/google/cloud/policy_troubleshooter/v1.rb,
lib/google/cloud/policy_troubleshooter/v1/version.rb,
lib/google/cloud/policy_troubleshooter/v1/iam_checker.rb,
lib/google/cloud/policy_troubleshooter/v1/iam_checker/client.rb,
lib/google/cloud/policy_troubleshooter/v1/iam_checker/credentials.rb,
proto_docs/google/cloud/policytroubleshooter/v1/checker.rb,
proto_docs/google/cloud/policytroubleshooter/v1/explanations.rb

Overview

To load this package, including all its services, and instantiate a client:

require "google/cloud/policy_troubleshooter/v1"
client = ::Google::Cloud::PolicyTroubleshooter::V1::IamChecker::Client.new

Defined Under Namespace

Modules: AccessState, HeuristicRelevance, IamChecker Classes: AccessTuple, BindingExplanation, ExplainedPolicy, TroubleshootIamPolicyRequest, TroubleshootIamPolicyResponse

Constant Summary collapse

VERSION =
"0.3.3"