Module: Google::Cloud::Spanner::Admin::Instance::V1

Defined in:
lib/google/cloud/spanner/admin/instance/v1.rb,
lib/google/cloud/spanner/admin/instance/v1/version.rb,
lib/google/cloud/spanner/admin/instance/v1/instance_admin.rb,
lib/google/cloud/spanner/admin/instance/v1/instance_admin/paths.rb,
lib/google/cloud/spanner/admin/instance/v1/instance_admin/client.rb,
lib/google/cloud/spanner/admin/instance/v1/instance_admin/operations.rb,
lib/google/cloud/spanner/admin/instance/v1/instance_admin/credentials.rb,
proto_docs/google/spanner/admin/instance/v1/spanner_instance_admin.rb

Overview

To load this package, including all its services, and instantiate a client:

require "google/cloud/spanner/admin/instance/v1"
client = ::Google::Cloud::Spanner::Admin::Instance::V1::InstanceAdmin::Client.new

Defined Under Namespace

Modules: InstanceAdmin Classes: CreateInstanceMetadata, CreateInstanceRequest, DeleteInstanceRequest, GetInstanceConfigRequest, GetInstanceRequest, Instance, InstanceConfig, ListInstanceConfigsRequest, ListInstanceConfigsResponse, ListInstancesRequest, ListInstancesResponse, ReplicaInfo, UpdateInstanceMetadata, UpdateInstanceRequest

Constant Summary collapse

VERSION =
"0.5.3"